alm -list fail

+alm -list fails

alm bootload_tape_label
ALM 8.14
r 19:03 2.377 29

alm bootload_tape_label -list
ALM 8.14
alm: Phase error while generating the object segment
alm: Fatal error.  Translation aborted. >user_dir_dir>SysEng>Anthony>fromSource
\c>work>bootload_tape_label.alm

Works on a small file:

cp >ldd>tools>source>etd3.alm
r 19:44 0.162 13

alm etd3
ALM 8.14
r 19:44 0.902 60

alm etd3 -list
ALM 8.14
r 19:44 0.813 15

status etd3.alm

names:    etd3.alm
type:               segment
date used:          08/08/93  1946.4 pdt Sun
date modified:      08/08/93  1944.8 pdt Sun
branch modified:    08/08/93  1944.6 pdt Sun
bit count:          3393
records used:       1
mode:               rew

And it works on really big ones…

ac x >ldd>sl1>s>bound_library_wired_.s pl1_operators_.alm
r 19:47 0.605 154

alm pl1_operators_.alm
ALM 8.14
r 19:48 46.089 148

alm pl1_operators_.alm -list
ALM 8.14
r 19:49 59.098 690

status pl1_operators_.alm

names:    pl1_operators_.alm
type:               segment
date used:          08/08/93  1955.9 pdt Sun
date modified:      08/08/93  1947.7 pdt Sun
branch modified:    08/08/93  1947.6 pdt Sun
bit count:          1807884
records used:       50
mode:               rew

r 19:55 0.078 0

It's something about that particular segment?

Nol; it depends on what directory I am in????

Yep; it assembles in [hd], [hd]>fromSource, but not [hd]>fromSource>work

Directory name length?

falis in [hd]>fromSource>worc

Different error message in [hd]>fromSource>wor

cwd wor
r 20:16 0.046 0

cp >ldd>sl1>s>bootload_tape_label.alm
r 20:16 0.088 5

alm bootload_tape_label -list
ALM 8.14

Error:  out_of_bounds at glpl_|6
(>system_library_standard>bound_alm_)
referencing 12321|277
There was an attempt to use an invalid segment number.
r 20:16 4.484 67 level 2

pwd
>user_dir_dir>SysEng>Anthony>fromSource>wor
r 20:16 0.048 6 level 2

fails in work1, work12, work123,

Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License